Error during sync

#1

Having an issue when I try to run the gms sync:

Traceback (most recent call last):
  File "/usr/bin/gms", line 11, in <module>
    sys.exit(gms())
  File "/usr/lib/python3.6/site-packages/click/core.py", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/click/core.py", line 697, in main
    rv = self.invoke(ctx)
  File "/usr/lib/python3.6/site-packages/click/core.py", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib/python3.6/site-packages/click/core.py", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib/python3.6/site-packages/click/core.py", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib/python3.6/site-packages/click/core.py", line 535, in invoke
    return callback(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/google_music_scripts/commands/sync.py", line 318, in sync_up
    delete_on_success=delete_on_success
  File "/usr/lib/python3.6/site-packages/google_music_scripts/core.py", line 138, in upload_songs
    song, transcode_lossless=transcode_lossless, transcode_lossy=transcode_lossy
  File "/usr/lib/python3.6/site-packages/google_music/clients/musicmanager.py", line 253, in upload
    track_info = mm_calls.Metadata.get_track_info(song)
  File "/usr/lib/python3.6/site-packages/google_music_proto/musicmanager/calls.py", line 271, in get_track_info
    track.track_number = int(track_split[0])
ValueError: invalid literal for int() with base 10: '13 16'
#2

From a quick glance, looks like an invalid track number in the ID3v2 tag. You can see discussion about another case of invalid ID3v2 fields and what might happen with that in the future in this issue.

To find any files that don’t load properly (and probably contain invalid tags), run this script in your music directory. It will print out the paths of any files that fail to load. You can send them to me by email at mail@thebigmunch.me if you want me to look at them to confirm. If it’s an invalid field, you can try to modify them in a tag editor to see if that will correct the issue.