Won't install cleanly in centos 7

I’m having trouble with installing in centos 7. I tried under anaconda python 3.6.6, and the system python 3.6.8.

Both are complaining about version incompatibilities.

Even though I clear it all out and try again:

python3 -m pip uninstall google-music google-music-proto google-music-scripts google-music-utils
python3 -m pip install google-music-scripts==4.1.1

… bunch of stuff…

ERROR: google-music-proto 2.5.1 has requirement audio-metadata<0.7,>=0.6, but you’ll have audio-metadata 0.5.0 which is incompatible.
ERROR: google-music-utils 2.2.1 has requirement audio-metadata<0.7,>=0.6, but you’ll have audio-metadata 0.5.0 which is incompatible.

python3 -m pip list | grep google
google-music 3.1.0
google-music-proto 2.5.1
google-music-scripts 4.1.1
google-music-utils 2.2.1

python3 -m pip list | grep audio
audio-metadata 0.5.0

But running this seems to work around the trouble:

python3 -m pip install google-music-proto==2.5.0

Uploading happily now… maybe you need to add a sanity check to your build regression test, and update some dependency loops or something?

Hope this helps.

Try using the upgrade option to pip install.

Oh, hmmm. Haven’t made a google-music release since the audio-metadata update. Forgot I was waiting for something to do that. I’ll get to that soon.

Should be settled now.